Problem med kanal på DS2450

I detta forum hör diskussioner gällande teknik i största allmänhet och hemautomation i synnerhet hemma.

Moderator: elf98

Kategoriregler
Vill du visa bilder i ditt inlägg? Använd funktionen "Ladda upp bilaga" nedanför textrutan!
fiddex
Wannabe
Inlägg: 11
Blev medlem: 21 mar 2015, 21:53
Ort: Trollhättan

Problem med kanal på DS2450

Inlägg av fiddex » 23 apr 2015, 11:19

Har köpt mig en https://www.m.nu/adomvandlare-kanaler-025v-p-307.html för att mäta batterispänningar, dock uteblir mätvärdet på A kanalen nån gång in emellan, vad kan detta bero på 1-wire nätet är kopplat med usb 9490r adaptern på en raspberry pi med owfs.
Användarvisningsbild
elf98
Hemautomation - det är mer än en hobby
Inlägg: 5223
Blev medlem: 27 okt 2006, 13:49
Ort: Linköping
Kontakt:

Re: Problem med kanal på DS2450

Inlägg av elf98 » 23 apr 2015, 20:54

Vilken mjukvara använder du?

Vad borde spänningen vara?

Ds2450 har två mätområde per kanal, 0-2,56V och 0-5,12V. Vilket av mätområdet läser du?

Om spänningen ligger utanför mätområdet rapporteras 0V.
Grundade m.nu & temperatur.nu

Bild Bild
fiddex
Wannabe
Inlägg: 11
Blev medlem: 21 mar 2015, 21:53
Ort: Trollhättan

Re: Problem med kanal på DS2450

Inlägg av fiddex » 26 apr 2015, 19:31

Vilken mjukvara använder du?
OS Debian Linux 7.6

Kör usr/lib/owfs/owfs version:
2.8p15
libow version:
2.8p15



Vad borde spänningen vara?
Ds2450 har två mätområde per kanal, 0-2,56V och 0-5,12V. Vilket av mätområdet läser du?
Runt 12-12.7 volt och det framgår vid utläsningen men ibland så hoppar den över A kanalen och svart blir precis tomt inte ens en lite nolla :(
så för att lösa detta problem just nu så fixade jag till så att den rullar in i en lopp med 10 försök. sen dess har det fungerat men känns som det är lite fel väg att gå, hade de andra kanalerna bettet sig lika dant så hade det vart lättare att köpa fenomenet.

Kod: Markera allt

#!/bin/bash 
for pid in $(pidof -x Volt.sh); do
    if [ $pid != $$ ]; then
        echo "[$(date)] : Volt.sh : Skiten är redan igång  PID $pid"
        exit 1
    fi
done


function VoltAA {
COUNTER=0
while [  $COUNTER -lt 10 ]; do
VoltA=$(cat /mnt/1wire/20.18DF0A000000/volt.A)

if [ "$VoltA" == "" ]
then
let COUNTER=COUNTER+1
echo $NOW ";Fel på VoltA "  >> /var/www/Felgivare.log 
else 
COUNTER=10 
fi
done
 }


function VoltBB {
COUNTER=0
while [  $COUNTER -lt 10 ]; do
VoltB=$(cat /mnt/1wire/20.18DF0A000000/volt.B)

if [ "$VoltB" == "" ]
then
let COUNTER=COUNTER+1
echo $NOW ";Fel på VoltB "  >> /var/www/Felgivare.log  
else 
COUNTER=10 
fi
done
 }




function VoltCC {
COUNTER=0
while [  $COUNTER -lt 10 ]; do
VoltC=$(cat /mnt/1wire/20.18DF0A000000/volt.C)


if [ "$VoltC" == "" ]
then
let COUNTER=COUNTER+1
echo $NOW ";Fel på VoltC "  >> /var/www/Felgivare.log  
else 
COUNTER=10 
fi
done
 }



function VoltDD {
COUNTER=0
while [  $COUNTER -lt 10 ]; do
VoltD=$(cat /mnt/1wire/20.18DF0A000000/volt.D)

if [ "$VoltD" == "" ]
then
let COUNTER=COUNTER+1 
echo $NOW ";Fel på VoltD "  >> /var/www/Felgivare.log 
else 
COUNTER=10 
fi
done
 }


for (( ; ; ))
do
clear

NOW=$(date +"%Y-%m-%d %H:%M:%S")

VoltAA
VoltBB
VoltCC
VoltDD



echo "$NOW ; $VoltA ; $VoltB ; $VoltC ; $VoltC" >> Volt_oraknad.csv


VoltA=$( echo $VoltA*5 | bc)
VoltB=$( echo $VoltB*5 | bc)
VoltC=$( echo $VoltC*5 | bc)
VoltD=$( echo $VoltD*5 | bc)


if [[ ${VoltA:0:1} == "." ]] ; then VoltA=$(echo 0$VoltA) ;  fi
if [[ ${VoltB:0:1} == "." ]] ; then VoltB=$(echo 0$VoltB) ;  fi
if [[ ${VoltC:0:1} == "." ]] ; then VoltC=$(echo 0$VoltC) ;  fi
if [[ ${VoltD:0:1} == "." ]] ; then VoltD=$(echo 0$VoltD) ;  fi



echo "$NOW; $VoltA; $VoltB; $VoltC; $VoltC" >> Volt.csv


sleep 10
done
Användarvisningsbild
elf98
Hemautomation - det är mer än en hobby
Inlägg: 5223
Blev medlem: 27 okt 2006, 13:49
Ort: Linköping
Kontakt:

Re: Problem med kanal på DS2450

Inlägg av elf98 » 26 apr 2015, 19:51

Se till att chipet är spännignsmatat (jumpern ska sitta på kortet och det ska ha 5V).

kör

Kod: Markera allt

echo 1 >power
Grundade m.nu & temperatur.nu

Bild Bild
fiddex
Wannabe
Inlägg: 11
Blev medlem: 21 mar 2015, 21:53
Ort: Trollhättan

Re: Problem med kanal på DS2450

Inlägg av fiddex » 26 apr 2015, 21:34

Stöter fortfarande på fel, verkar dock som om att det bara behövs en omläsning för att få tag på rätt värde, fortfarande bara på A kanalen, kör med
USB 1wire (DS9490R) har dock inte rört bygeln, men den sitter där precis vid RJ11/12 uttaget ?
Användarvisningsbild
elf98
Hemautomation - det är mer än en hobby
Inlägg: 5223
Blev medlem: 27 okt 2006, 13:49
Ort: Linköping
Kontakt:

Re: Problem med kanal på DS2450

Inlägg av elf98 » 27 apr 2015, 10:05

2.8.15 är från 2012, och det har släppts en stor mängd nya releaser med buggfixar sedan dess! Får du samma fel om du kör senaste versionen av owfs?
Grundade m.nu & temperatur.nu

Bild Bild
Dale
Tar hemautomation på allvar
Inlägg: 67
Blev medlem: 18 nov 2007, 10:38
Ort: Upplands Väsby / Älvdalen

Re: Problem med kanal på DS2450

Inlägg av Dale » 27 apr 2015, 10:59

Har liknande problem med två separata system (en i husvagn och den andra hemma) Kör man enkla vägen med sudo apt-get install owfs och oavsett jag försöker uppdatera/uppgradera blire inget nyare än 2.8p15 ser på http://sourceforge.net/projects/owfs/files/owfs/ att det finns 3.1p0. Drar mig själv för att uppdatera "manuellt" ifa nått blir på tok.
\\d
4 Net, 3 Duo, 14 RPi, 2 reporter & 64+ givare
This message was made using 100% recycled electrons!
fiddex
Wannabe
Inlägg: 11
Blev medlem: 21 mar 2015, 21:53
Ort: Trollhättan

Re: Problem med kanal på DS2450

Inlägg av fiddex » 27 apr 2015, 21:40

Provade med att avinstallerat owfs för att sen hämta och installera den senaste versionen 3.1p0 , lyckas inte riktigt med detta. Så blev en ominstallation av 2015-02-16-raspbian-wheezy och gjorde på följande sätt.

Kod: Markera allt

apt-get update
apt-get upgrade

sudo apt-get -y install automake autoconf autotools-dev gcc g++ libtool libusb-dev libfuse-dev swig python2.7-dev tcl8.4-dev php5-dev make build-essential


cd /usr/src
sudo wget  -O owfs-3.1p0.tar.gz http://downloads.sourceforge.net/project/owfs/owfs/3.1p0/owfs-3.1p0.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fowfs%2Ffiles%2Fowfs%2F3.1p0%2F&ts=1430136504&use_mirror=vorboss

sudo tar xzvf owfs-3.1p0.tar.gz

cd /usr/src/owfs-3.1p0
sudo ./configure

sudo make -j 4 && sudo make install 



sudo nano /etc/modprobe.d/blacklist.conf

# Prohibit interference with OWFS
blacklist ds2490
blacklist wire


sudo nano /etc/fuse.conf
#user_allow_other
till
user_allow_other


sudo mkdir /mnt/1wire

sudo /opt/owfs/bin/owfs -u --allow_other /mnt/1wire/


men det vill sig inte katalogen är helt tom.

så körde

Kod: Markera allt

sudo /opt/owfs/bin/owfs --error_level 6 --error_print 2 -u --allow_other /mnt/1wire/

# Resultatet då blir
DEFAULT: ow_arg.c:(552) USB support (intentionally) not included in compilation. Check LIBUSB, then reconfigure and recompile.
DEBUG: ow_exit.c:(17) Exit code = 0


Hur går jag vidare, eller vad har jag missat ?
Användarvisningsbild
elf98
Hemautomation - det är mer än en hobby
Inlägg: 5223
Blev medlem: 27 okt 2006, 13:49
Ort: Linköping
Kontakt:

Re: Problem med kanal på DS2450

Inlägg av elf98 » 27 apr 2015, 22:16

Vad visar:
sudo ./configure
Grundade m.nu & temperatur.nu

Bild Bild
fiddex
Wannabe
Inlägg: 11
Blev medlem: 21 mar 2015, 21:53
Ort: Trollhättan

Re: Problem med kanal på DS2450

Inlägg av fiddex » 28 apr 2015, 23:11

Känns som om att det saknas nått lyckas inte med att få med USB adaptern.

Kod: Markera allt

/bin/rm: cannot remove `libtoolT': No such file or directory

Current configuration:

    Deployment location: /opt/owfs

Compile-time options:
                      USB is DISABLED
                    AVAHI is DISABLED
                      I2C is enabled
                       W1 is enabled
    Parallel port DS1410E is enabled
         Zeroconf/Bonjour is enabled
             Debug-output is enabled
               Mutexdebug is enabled
                Profiling is DISABLED
Tracing memory allocation is DISABLED

Module configuration:
                    owlib is enabled
                  owshell is enabled
                     owfs is enabled
                  owhttpd is enabled
                   owftpd is enabled
                 owserver is enabled
               owexternal is enabled
                    ownet is enabled
                 ownetlib is enabled
                    owtap is enabled
                    owmon is enabled
                   owcapi is enabled
                     swig is enabled
                   owperl is enabled
                    owphp is DISABLED
                 owpython is enabled
                    owtcl is enabled
larky
Moderator
Inlägg: 1136
Blev medlem: 01 feb 2008, 12:21
Ort: Skellefteå
Kontakt:

Re: Problem med kanal på DS2450

Inlägg av larky » 29 apr 2015, 07:07

sudo apt-get install libusb-dev
fiddex
Wannabe
Inlägg: 11
Blev medlem: 21 mar 2015, 21:53
Ort: Trollhättan

Re: Problem med kanal på DS2450

Inlägg av fiddex » 29 apr 2015, 07:48

Finns redan med

Kod: Markera allt

sudo apt-get -y install automake autoconf autotools-dev gcc g++ libtool libusb-dev libfuse-dev swig python2.7-dev tcl8.4-dev php5-dev make build-essential
Användarvisningsbild
elf98
Hemautomation - det är mer än en hobby
Inlägg: 5223
Blev medlem: 27 okt 2006, 13:49
Ort: Linköping
Kontakt:

Re: Problem med kanal på DS2450

Inlägg av elf98 » 29 apr 2015, 08:09

Här finns mer info om liknande problem:
https://bugs.mysql.com/bug.php?id=50067
Grundade m.nu & temperatur.nu

Bild Bild
Skriv svar