RasbberryPi GPIO och långa kablar

I detta forum hör diskussioner gällande teknik i största allmänhet och hemautomation i synnerhet hemma.

Moderator: elf98

Kategoriregler
Vill du visa bilder i ditt inlägg? Använd funktionen "Ladda upp bilaga" nedanför textrutan!
gnagis
Tar hemautomation på allvar
Inlägg: 82
Blev medlem: 14 maj 2009, 10:08
Ort: Stockholm

RasbberryPi GPIO och långa kablar

Inlägg av gnagis » 07 jun 2017, 20:26

Hej
På en ca 20-25m lång nätverkskabel så har jag monterat 5st DS1820 sensorer.
Den kabeln har jag sedan kopplat in på en RPi till stiften 3,3V, OV och GPIO4(med pull-up motstånd)
På RPi:n så kör jag Domoticz.
Om jag kör "ls /sys/bus/w1/devices/" så hittas inga sensorer.
Kopplar jag in 1 sensor "direkt" mot RPi:n så hittas sensorn via kommandot och jag får upp temp-värdet i Domoticz.
Min koppling
Min koppling
RPi 1wire.PNG (37.77 KiB) Visad 2784 gånger
Jag testade med 1 sensor och lite kortare kabel 5-6 m och det funkar inte heller.

Vad jag har förstått sen tidigare så ska det gå att använda vanlig nätverkskabel ?

Hoppas någon vänlig själ kan hjälpa mig med detta.
gnagis
Tar hemautomation på allvar
Inlägg: 82
Blev medlem: 14 maj 2009, 10:08
Ort: Stockholm

Re: RasbberryPi GPIO och långa kablar

Inlägg av gnagis » 09 jun 2017, 14:06

Jag fattar inte varför det inte funkar.
Nu har jag testat med att koppla in en USB/1wire adapter DS9490R.
Från den går jag med 3 kablar(5V, DQ, GND) till en liten lab-plint.
På den så har jag satt en tempsensor DS18S20, ansluten till dom 3 kablarna.
Den sensorn dyker upp direkt när jag kör " ls /sys/bus/w1/devices/"
Men när jag kopplar in en sensor med några meter kabel, så syns den sensorn inte nu heller.
Så varken via 1wire GPIO eller USB/1wire-adaptern så funkar det inte. Kopplar jag däremot sensorn direkt till lab-plinten så hittas den.

Nånl som kan ha någon idé ?
Användarvisningsbild
Plutonium
Moderator
Inlägg: 1243
Blev medlem: 04 jan 2008, 02:34
Ort: Nossebro
Kontakt:

Re: RasbberryPi GPIO och långa kablar

Inlägg av Plutonium » 10 jun 2017, 17:09

Rent spontant känns 20-25m ganska långt för 3,3V. Har du mätt längst ut vad du har för spänning, kanske ligger precis på gränsen? I och med att det fungerar med DS9490R så levererar den ca 5V.
http://essunga.org
Moderator - Temperatur.nu
gnagis
Tar hemautomation på allvar
Inlägg: 82
Blev medlem: 14 maj 2009, 10:08
Ort: Stockholm

Re: RasbberryPi GPIO och långa kablar

Inlägg av gnagis » 10 jun 2017, 19:25

Den långa kabeln kan jag tyvärr inte mäta i änden på, för den ligger nedgrävd tillsammans med Vatten&avlopp -slangar som ligger i frigolitlådor som i sin tur är nedgrävda :-(
Oavsett om jag går via GPIO eller USB-adaptern så slutar det fungera, så fort jag börjar koppla med några meter kabel till en sensor.
gnagis
Tar hemautomation på allvar
Inlägg: 82
Blev medlem: 14 maj 2009, 10:08
Ort: Stockholm

Re: RasbberryPi GPIO och långa kablar

Inlägg av gnagis » 16 jun 2017, 10:16

Varför slutar det fungera så fort jag lägger någon/några meter kabel till sensorn ?
(jag använder alltså 3 ledare i en vanlig UTP nätverkskabel)
Användarvisningsbild
Plutonium
Moderator
Inlägg: 1243
Blev medlem: 04 jan 2008, 02:34
Ort: Nossebro
Kontakt:

Re: RasbberryPi GPIO och långa kablar

Inlägg av Plutonium » 16 jun 2017, 19:26

Det är lite märkligt må jag säga, har suttit och kollat på alternativa kopplingar för ds18s20 men enligt schemat du postat så ser det rätt ut. Vad för motstånd kör du med?
http://essunga.org
Moderator - Temperatur.nu
gnagis
Tar hemautomation på allvar
Inlägg: 82
Blev medlem: 14 maj 2009, 10:08
Ort: Stockholm

Re: RasbberryPi GPIO och långa kablar

Inlägg av gnagis » 17 jun 2017, 09:16

2st parallell-kopplade på vardera 100k (brun-svart-gul), 50k alltså.
gnagis
Tar hemautomation på allvar
Inlägg: 82
Blev medlem: 14 maj 2009, 10:08
Ort: Stockholm

Re: RasbberryPi GPIO och långa kablar

Inlägg av gnagis » 17 jun 2017, 09:42

@Plutonium Huvet på spiken ! Där har jag ju felet :-)
Supertack för din fråga :-)
Måste vara färgblind eller nåt när jag plockade fram motsånden.
Testar nu med ett 4,7K och det fungerar kanon med ca 10 m kabel.
Användarvisningsbild
Plutonium
Moderator
Inlägg: 1243
Blev medlem: 04 jan 2008, 02:34
Ort: Nossebro
Kontakt:

Re: RasbberryPi GPIO och långa kablar

Inlägg av Plutonium » 18 jun 2017, 00:19

Vad skönt att det löste sig tillslut och att det inte var krångligare än så ;)
http://essunga.org
Moderator - Temperatur.nu
Skriv svar