Ingen OWFS-fil!!

OWFS - One Wire File System är en Linuxmjukvara som stödjer de flesta kommersiellt tillgängliga 1wire-enheterna. OWFS saknar helt möjligheter att presentera data - detta måste göras med tex RRDTool

Moderator: elf98

Kategoriregler
Vill du visa bilder i ditt inlägg? Använd funktionen "Ladda upp bilaga" nedanför textrutan!
sm7rdx
Tar hemautomation på allvar
Inlägg: 124
Blev medlem: 17 feb 2010, 20:38
Ort: Kalmar
Kontakt:

Ingen OWFS-fil!!

Inlägg av sm7rdx » 17 feb 2010, 20:45

Hallå!
Ny här. Har försökt installera OWFS på en Debian Lenny.
Kompilerat enligt instruktionerna i tar-filen. Jag får en massa
filer i /opt/owfs/bin men ingen owfs.
I slutet på make install ser jag raden
owfs DISABLED
Det borde väl inte stå så?

Vad gör jag för fel? :?:
Användarvisningsbild
Plutonium
Moderator
Inlägg: 1241
Blev medlem: 04 jan 2008, 02:34
Ort: Nossebro
Kontakt:

Re: Ingen OWFS-fil!!

Inlägg av Plutonium » 17 feb 2010, 20:52

Det finns en flagga du kan nyttja. Testa det. Du har laddat modueln fuse också?

Kod: Markera allt

./configure --enable-owfs

Kod: Markera allt

modprobe fuse
http://essunga.org
Moderator - Temperatur.nu
sm7rdx
Tar hemautomation på allvar
Inlägg: 124
Blev medlem: 17 feb 2010, 20:38
Ort: Kalmar
Kontakt:

Re: Ingen OWFS-fil!!

Inlägg av sm7rdx » 17 feb 2010, 21:51

Ok, ett steg närmare kom jag, men inte hela vägen:

Kod: Markera allt

/opt/owfs/bin/owfs: error while loading shared libraries: libfuse.so.2: cannot open shared object file: No such file or directory
debian:/home/temp/owfs-2.7p26# 
fuse-2.8.3 finns men vad hände?
bive
Inlägg: 2
Blev medlem: 01 feb 2010, 23:47
Ort: Skamhed

Re: Ingen OWFS-fil!!

Inlägg av bive » 18 feb 2010, 21:28

sm7rdx skrev:Ok, ett steg närmare kom jag, men inte hela vägen:

Kod: Markera allt

/opt/owfs/bin/owfs: error while loading shared libraries: libfuse.so.2: cannot open shared object file: No such file or directory
debian:/home/temp/owfs-2.7p26# 
fuse-2.8.3 finns men vad hände?
Har du installerat följande:
libfuse-dev
libfuse2

Kör själv på Debian Lenny och fick inga problem med min OWFS-installation.
sm7rdx
Tar hemautomation på allvar
Inlägg: 124
Blev medlem: 17 feb 2010, 20:38
Ort: Kalmar
Kontakt:

Re: Ingen OWFS-fil!!

Inlägg av sm7rdx » 19 feb 2010, 17:38

Libfuse-dev och libfuse2 hade jag givetvis inte installerat.
Nu blev det inga protester och owfs kör som det ska. :D

Detta är ett bekymmer jag har haft hela tiden med Linux. Att man
behöver annat förutom de program man egentligen ska använda.
Jag såg att hela processen bygger på fuse, alltså hämtade jag fuse.
Men *-dev m.m. var inget självklart.

Detta gör att forum som detta är ovärderligt för en non-hacker som jag.
Jag tackar för hjälpen, livet blir enklare för en Linux-user som jag
med hjälp av de som kan. :D
Skriv svar