Problem installation OWFS

OWFS - One Wire File System är en Linuxmjukvara som stödjer de flesta kommersiellt tillgängliga 1wire-enheterna. OWFS saknar helt möjligheter att presentera data - detta måste göras med tex RRDTool

Moderator: elf98

Kategoriregler
Vill du visa bilder i ditt inlägg? Använd funktionen "Ladda upp bilaga" nedanför textrutan!
zorro_66
Wannabe
Inlägg: 17
Blev medlem: 10 jan 2014, 20:19
Ort: Uppland

Problem installation OWFS

Inlägg av zorro_66 » 02 jun 2015, 14:44

Har stött på ett problem vid installation av owfs
detta är min första kontakt med owfs
jag har följt guiden i wikin
men får följande fel :oops: :oops:
pi@raspberrypi ~ $ sudo /usr/bin/owfs --i2c=ALL:ALL --allow_other /mnt/1wire/
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option

Jag använder en R-pi i2c 1wire expansion module [v1.1]
Raspberry Pi V2 med senaste Raspbian på
har sökt på forumet men hittar inget liknande fel
har säkert gjort något fatalt fel inte lätt detta med Linux när man är född Windows kille :mrgreen: :mrgreen:
larky
Moderator
Inlägg: 1125
Blev medlem: 01 feb 2008, 12:21
Ort: Skellefteå
Kontakt:

Re: Problem installation OWFS

Inlägg av larky » 02 jun 2015, 19:39

Vad ger
sudo ls -l /mnt/1wire
cstek
Wannabe
Inlägg: 4
Blev medlem: 06 jan 2016, 19:49
Ort: Åland

Re: Problem installation OWFS

Inlägg av cstek » 06 jan 2016, 20:29

Har kört fast när jag försöker få igång 1wire på en gammal pi med ny Domoticz installation och kör 1wire med en usb adapter DS9490R
Får samma fel som TS, kör jag
sudo ls -l /mnt/1wire
får jag följande:
pi@raspberrypi ~ $ sudo ls -l /mnt/1wire
total 0
drwxrwxrwx 1 root root 8 Jan 6 20:00 05.4AEC29CDBAAB
drwxrwxrwx 1 root root 8 Jan 6 20:00 10.67C6697351FF
drwxr-xr-x 1 root root 8 Jan 6 19:18 alarm
drwxr-xr-x 1 root root 8 Jan 6 19:18 bus.0
drwxr-xr-x 1 root root 8 Jan 6 19:18 bus.1
drwxr-xr-x 1 root root 8 Jan 6 19:18 settings
drwxrwxrwx 1 root root 8 Jan 6 20:00 simultaneous
drwxr-xr-x 1 root root 8 Jan 6 19:18 statistics
drwxr-xr-x 1 root root 32 Jan 6 19:18 structure
drwxr-xr-x 1 root root 8 Jan 6 19:18 system
drwxr-xr-x 1 root root 8 Jan 6 19:18 uncached

Kan man säga något av det?
Är helt grön på Linux och har följt Wikin OWFS på Raspberry Pi rakt av.
Är inte helt säker på hårdvaran heller, har en ds18B20 inkopplad, men kan man säga något av det här först?
cstek
Wannabe
Inlägg: 4
Blev medlem: 06 jan 2016, 19:49
Ort: Åland

Re: Problem installation OWFS

Inlägg av cstek » 07 jan 2016, 00:07

Svarar på det själv, efter felsökande och läsande provade jag att sätta in -uall istället för -u som det står i Wikin att man ska göra när man använder
USB adaptern i den här raden "sudo /usr/bin/owfs --i2c=ALL:ALL --allow_other /mnt/1wire/".
flyvert
Hemautomation - det är mer än en hobby
Inlägg: 388
Blev medlem: 22 aug 2013, 00:48
Ort: Västerås

Re: Problem installation OWFS

Inlägg av flyvert » 07 jan 2016, 11:03

cstek skrev:kör jag
sudo ls -l /mnt/1wire
får jag följande:
pi@raspberrypi ~ $ sudo ls -l /mnt/1wire
total 0
drwxrwxrwx 1 root root 8 Jan 6 20:00 05.4AEC29CDBAAB
drwxrwxrwx 1 root root 8 Jan 6 20:00 10.67C6697351FF
...
owfs förutsätter att katalogen den skall skapa 1-wire filträdet på är tom.
Din kontrolläsning (ls /mnt/1wire) visar att den inte är det. Innehållet ser mycket likt en körande OWFS! :D

Med ovanstående output är felet "fuse: mountpoint is not empty" helt i sin ordning - katalogen är upptagen!!

Min gissning är att du gjort en "apt-get install owfs" och fått en automatiskt startande owfs (som då skapar dessa filer om allt stämmer med konfig-filen vid boot av Raspberryn). Då går det inte att starta en ny instans av owfs processen på samma katalog. Alternativt så har du redan tidigare lyckats starta en OWFS process, t.ex. via kommandoraden, och då misslyckas du om du försöker starta en till på samma "arbetskatalog".

Med "ps ax | grep owfs" kan du se om det redan går en owfs-process.

Dessutom gissar jag på att om du gör "cd" ner i någon av katalogerna med långa namn (tex 05.4AEC29CDBAAB) och gör "cat" på de underliggande filerna som ligger däri, t.ex. "temperature" (om det är en termometer) så får du upp givarvärden... dvs du har OWFS igång redan!

Som du själv upptäckt skall parametern "--i2c=ALL:ALL" inte användas när du har USB adapter...
Om traktorn stjälper; håll i ratten, hoppa ej!
cstek
Wannabe
Inlägg: 4
Blev medlem: 06 jan 2016, 19:49
Ort: Åland

Re: Problem installation OWFS

Inlägg av cstek » 07 jan 2016, 16:17

Jo kom fram till att jag den redan var igång, blev lite ihopblandat mitt eget svar som jag skrev igår...

Installerade om enligt WiKi och på så sätt blev den tömd antar jag. Jag fick inte upp givaren genom att följa Wikin hur man skall göra med USb adaptern, utan som jag nämnde i mitt svar måste jag byta ut -u mot -uall för att givaren skulle dyka upp?
Säkert något uppenbart fel jag gjort men är totalt nybörjare på det här.
Återkommer säkert med fler frågor :)
Skriv svar