9490R + Vista

Generella Windowsfrågor och frågor gällande Windowsmjukvara som saknar egen forumkategori skall postas i detta forum

Moderator: elf98

Kategoriregler
Vill du visa bilder i ditt inlägg? Använd funktionen "Ladda upp bilaga" nedanför textrutan!
PerM
Hemautomation - det är mer än en hobby
Inlägg: 822
Blev medlem: 23 feb 2007, 14:46
Ort: Vallentuna
Kontakt:

9490R + Vista

Inlägg av PerM » 20 dec 2007, 21:23

Hej,

Är det någon som lyckats installera en 9490R under Vista? Den vill inte acceptera de drivruter som Maxim skeppar. Hittar inte heller något på nätet om problem med denna enhet... hjälp!

Edit: Ibland kan jag inte stava....
Edit2: Den fungerar under XP

sjolof
Wannabe
Inlägg: 7
Blev medlem: 24 okt 2007, 22:53
Ort: Lysekil

Re: 9490R + Vista

Inlägg av sjolof » 21 dec 2007, 01:36

PerM skrev:Hej,

Är det någon som lyckats installera en 9490R under Vista? Den vill inte acceptera de drivruter som Maxim skeppar. Hittar inte heller något på nätet om problem med denna enhet... hjälp!

Edit: Ibland kan jag inte stava....
Edit2: Den fungerar under XP
Tjena

Har nu under ungefär två månaders tid haft korr med en kille på Maxim som försökt hjälpa mig lyckas med drivrutinsinstallationen på Vista.
Även för mig funkar anläggningen i XP.
I Vista så letar den drivrutin så fort jag ansluter enheten och klagar sedan över att den inte hittar nån fil...
Har väl kommit så långt att jag misstänker att det kanske har att göra med att jag har svenskt os.
Just nu ganska trött på felsöka...

Snälla... Om nån vet nåt... Skriv!!!

PerM
Hemautomation - det är mer än en hobby
Inlägg: 822
Blev medlem: 23 feb 2007, 14:46
Ort: Vallentuna
Kontakt:

Inlägg av PerM » 21 dec 2007, 10:37

Jag har engelsk Vista Premium men det hjälper inte...

sjolof
Wannabe
Inlägg: 7
Blev medlem: 24 okt 2007, 22:53
Ort: Lysekil

Inlägg av sjolof » 22 dec 2007, 00:26

PerM skrev:Jag har engelsk Vista Premium men det hjälper inte...
Bra, men tråkig information... Då stryker vi språkspåret...

PerM
Hemautomation - det är mer än en hobby
Inlägg: 822
Blev medlem: 23 feb 2007, 14:46
Ort: Vallentuna
Kontakt:

Inlägg av PerM » 22 dec 2007, 00:54

Vad har dom bett dig prova? Vore intressant att veta, kanske kan ge uppslag till nya ideér...

sjolof
Wannabe
Inlägg: 7
Blev medlem: 24 okt 2007, 22:53
Ort: Lysekil

Inlägg av sjolof » 22 dec 2007, 01:32

PerM skrev:Vad har dom bett dig prova? Vore intressant att veta, kanske kan ge uppslag till nya ideér...
Skicka mig ett mail på: magnus@acme-media.se så kan jag skicka all korr jag haft med Maxim, om du vill.

Fick detta svaret från Maxim för en liten stund sedan, så det finns nog hopp:
Thanks for letting me know. I'll see if I can get my hands on Vista premium and install it somewhere. Hopefully, we can get a handle on what is going on. I may have something for you to try after the holidays (a modified inf file)...

/Magnus

PerM
Hemautomation - det är mer än en hobby
Inlägg: 822
Blev medlem: 23 feb 2007, 14:46
Ort: Vallentuna
Kontakt:

Inlägg av PerM » 22 dec 2007, 02:40

Du kan skicka honom till min blog-post nedan, för JAG HAR LÖST DET! :D :D :D

Fan va jag är bra :shock:

http://www.pmalmberg.com/2007/12/22/how ... ows-vista/

sjolof
Wannabe
Inlägg: 7
Blev medlem: 24 okt 2007, 22:53
Ort: Lysekil

Inlägg av sjolof » 22 dec 2007, 10:07

PerM skrev:Du kan skicka honom till min blog-post nedan, för JAG HAR LÖST DET! :D :D :D

Fan va jag är bra :shock:

http://www.pmalmberg.com/2007/12/22/how ... ows-vista/
Dra mig i bakbenen... Detta får provas så fort jag kommer hem!!!

sjolof
Wannabe
Inlägg: 7
Blev medlem: 24 okt 2007, 22:53
Ort: Lysekil

Inlägg av sjolof » 23 dec 2007, 00:14

sjolof skrev:
PerM skrev:Du kan skicka honom till min blog-post nedan, för JAG HAR LÖST DET! :D :D :D

Fan va jag är bra :shock:

http://www.pmalmberg.com/2007/12/22/how ... ows-vista/
Dra mig i bakbenen... Detta får provas så fort jag kommer hem!!!
Du får dra mig i frambenen också... DET FUNKADE DIREKT !!!
Dock är jag lat av naturen så jag kopierade bara winusb-filen till /inf och ominstallerade drivrutinen... Funkade med en gång. Får nästan lust att kräkas eller nåt.

STORT TACK!!!

Jag kan bara inte låta bli att klistra in lite av min korr med Maxim...
Förlåt för längden på inlägget...
Hi. I wish I could tell which file is "not present". In any case, we have
a new 1-Wire Drivers release, you might try that:

http://www.maxim-ic.com/products/ibutto ... /index.cfm

Make sure you uninstall previous driver installs first before you install
the new drivers.

--Brian Hindman,
Maxim Integrated Products, Dallas

> -----Original Message-----
> From: magnus@sealeaf.se [mailto:magnus@sealeaf.se]
> Sent: Wednesday, December 19, 2007 3:20 PM
> To: Brian Hindman
> Subject: Re: FW: Can't send an attachment to you
>
>
> Brian
>
> Sorry for the delay.
> No luck with the new DPInst...
> Behaving the same...
>
> Sorry
>
> /Magnus
>
> > Hi. There is a multi-lingual version of DPInst.exe. See
> attached. Just
> > unzip the executable and copy over the other one. Let me know the
> > results.
> >
> > --Brian Hindman,
> > Maxim Integrated Products, Dallas
> >
> > -----Original Message-----
> > From: Sjölöfs [mailto:sjolof@gmail.com]
> > Sent: Monday, December 03, 2007 2:30 PM
> > To: Brian Hindman
> > Subject: Re: Can't send an attachment to you
> >
> >
> > Brian,
> >
> > Sorry, no success. Still the same.... Driver installation
> seems fine, but
> > when plugging in the DS it starts again to look for a
> driver. And it end
> > with that driver installation fails.
> > You can see it in the text below.
> > It says that "file can´t be found. Driver installation
> ended with errors".
> > In logfile: (Error code 0x2: Det går inte att hitta filen.)
> >
> > Hope this help you understand whats happning.
> > I also noticed in the text below:
> > "INFO: DPInst is not multi-lingual."
> > Do not know if that matters. (I´m using Swedish Vista)
> >
> > /Magnus
> >
> > INFO: 12/03/2007 20:45:55
> > INFO: Product Version 2.1.0.0 <http://2.1.0.0> .
> > INFO: Version: 6.0.6000
> > INFO: Platform ID: 2 (NT)
> > INFO: Service Pack: 0.0
> > INFO: Suite: 0x0300, Product Type: 1
> > INFO: Architecture: X86.
> > INFO: Interactive Windows Station
> > INFO: Command Line:
> > '"C:\Users\admin\Desktop\ds2490WinUSBInstall\DPInst.exe" /F'
> > INFO: DPInst is not multi-lingual.
> > INFO: ****************************************
> > INFO: Current working directory:
> > 'C:\Users\admin\Desktop\ds2490WinUSBInstall'
> > INFO: Running on path 'C:\Users\admin\Desktop\ds2490WinUSBInstall'
> > INFO: No valid 'dpinst.xml' file provided.
> > INFO: Install option set: Force install if driver is not better.
> > INFO: Found driver package:
> > 'C:\Users\admin\Desktop\ds2490WinUSBInstall\ds2490winusb_x86.inf'.
> > INFO: Preinstalling
> >
> 'c:\users\admin\desktop\ds2490winusbinstall\ds2490winusb_x86.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> >
> SUCCESS:c:\users\admin\desktop\ds2490winusbinstall\ds2490winus
> b_x86.inf is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0x0)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> >
> 'c:\users\admin\desktop\ds2490winusbinstall\ds2490winusb_x86.i
> nf' (Plug
> > and
> > Play).
> > INFO: Looking for Model Section [DS2490_WinUSB.NTx86]...
> > INFO: Installing devices with Id
> "USB\VID_04FA&PID_2490&REV_0002" using
> > INF
> >
> "C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf".
> > INFO: Installation did not occur because the hardware
> isn't currently
> > present.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: No drivers installed. No devices found that match driver(s)
> > contained in
> >
> 'C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf'.
> > INFO: RETURN: DriverPackageInstallW (0xE000020B)
> > INFO: No matching device was found for
> >
> 'c:\users\admin\desktop\ds2490winusbinstall\ds2490winusb_x86.i
> nf'. Driver
> > will be installed when plugged in.
> > INFO: Created entry in Add or Remove Programs for
> >
> 'C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf'.
> > INFO: Returning with code 0x100
> > INFO: 12/03/2007 20:47:14
> > INFO: ****************************************
> > INFO: 12/03/2007 21:23:33
> > INFO: Product Version 2.1.0.0 <http://2.1.0.0> .
> > INFO: Version: 6.0.6000
> > INFO: Platform ID: 2 (NT)
> > INFO: Service Pack: 0.0
> > INFO: Suite: 0x0300, Product Type: 1
> > INFO: Architecture: X86.
> > INFO: Interactive Windows Station
> > INFO: Command Line:
> > '"C:\Users\admin\Desktop\ds2490WinUSBInstall\DPInst.exe" /f'
> > INFO: DPInst is not multi-lingual.
> > INFO: ****************************************
> > INFO: Current working directory:
> > 'C:\Users\admin\Desktop\ds2490WinUSBInstall'
> > INFO: Running on path 'C:\Users\admin\Desktop\ds2490WinUSBInstall'
> > INFO: No valid 'dpinst.xml' file provided.
> > INFO: Install option set: Force install if driver is not better.
> > INFO: Found driver package:
> > 'C:\Users\admin\Desktop\ds2490WinUSBInstall\ds2490winusb_x86.inf'.
> > INFO: Preinstalling
> >
> 'c:\users\admin\desktop\ds2490winusbinstall\ds2490winusb_x86.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\admin\desktop\ds2490winusbinstall\ds2490winusb_x86.inf'.
> >
> SUCCESS:c:\users\admin\desktop\ds2490winusbinstall\ds2490winus
> b_x86.inf is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> >
> 'c:\users\admin\desktop\ds2490winusbinstall\ds2490winusb_x86.i
> nf' (Plug
> > and
> > Play).
> > INFO: Looking for Model Section [DS2490_WinUSB.NTx86]...
> > INFO: Installing devices with Id
> "USB\VID_04FA&PID_2490&REV_0002" using
> > INF
> >
> "C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf".
> > INFO: ENTER UpdateDriverForPlugAndPlayDevices...
> > ERROR: RETURN UpdateDriverForPlugAndPlayDevices. (Error
> code 0x2: Det går
> > inte att hitta filen.)
> > ERROR: Installation failed. (Error code 0x2: Det går inte att hitta
> > filen.)
> > ERROR: PnP Install failed. (Error code 0x2: Det går inte att hitta
> > filen.)
> > INFO: Attempting to rollback ...
> > INFO: No devices to rollback
> > INFO: RETURN: DriverPackageInstallW (0x2)
> > INFO: Returning with code 0x80010000
> > INFO: 12/03/2007 21:24:15
> >
> >
> >
> > 2007/12/3, Brian Hindman < Brian.Hindman@dalsemi.com
> > <mailto:Brian.Hindman@dalsemi.com> >:
> >
> > Hi. Try running DPInst.exe from a command-line and pass it the "/f"
> > switch
> > like this:
> >
> > dpinst.exe /f
> >
> >
> >
> > The "/f" switch sets the forceIfDriverIsNotBetter flag to ON, which
> > configures DPInst to install a driver on a device even if
> the driver that
> > is
> > currently installed on the device is a better match than
> the new driver.
> >
> > Hopefully, this will overwrite the "phantom node" that your log file
> > shows.
> > Let me know if this works for you.
> >
> >
> > Regards,
> > --Brian Hindman,
> > Maxim Integrated Products, Dallas
> >
> >
> > -----Original Message-----
> > From: Sjölöfs [mailto: <mailto:sjolof@gmail.com> sjolof@gmail.com]
> >
> > Sent: Friday, November 30, 2007 5:28 PM
> > To: Brian Hindman
> > Subject: Re: Can't send an attachment to you
> >
> >
> >
> > Brian
> >
> > See below for the results in my DPINST.txt file.
> > It still doesnt work for me, still claiming that "file is
> missing" when
> > installing drivers...
> >
> > Would be very happy if you could have a look at the text
> below and give me
> > a
> > comment.
> >
> > /Magnus
> >
> > DPINST.txt:
> > INFO: 11/30/2007 23:14:22
> > INFO: Product Version 2.1.0.0 <http://2.1.0.0/> .
> > INFO: Version: 6.0.6000
> > INFO: Platform ID: 2 (NT)
> > INFO: Service Pack: 0.0
> > INFO: Suite: 0x0300, Product Type: 1
> > INFO: Architecture: X86.
> > INFO: Interactive Windows Station
> > INFO: Command Line:
> > '"C:\Users\Caroline\Desktop\1wire\test\DPInst\DPInst.exe" '
> > INFO: DPInst is not multi-lingual.
> > INFO: ****************************************
> > INFO: Current working directory:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: Running on path
> 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: No valid 'dpinst.xml' file provided.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\ds2490winusb_x86.inf'.
> > INFO: Preinstalling
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf'.
> >
> SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\ds2490winu
> sb_x86.inf
> > is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.
> inf' (Plug
> > and
> > Play).
> > INFO: Looking for Model Section [DS2490_WinUSB.NTx86]...
> > INFO: Installing devices with Id
> "USB\VID_04FA&PID_2490&REV_0002" using
> > INF
> >
> "C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf".
> > INFO: Installation did not occur because the hardware
> isn't currently
> > present.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Failed to get rescan data for Phantom Device with
> > Hardware/Compatible Id 'USB\VID_04FA&PID_2490&REV_0002'.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: No drivers installed. No devices found that match driver(s)
> > contained in
> >
> 'C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf'.
> > INFO: RETURN: DriverPackageInstallW (0xE000020B)
> > INFO: No matching device was found for
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.
> inf'. Driver
> > will be installed when plugged in.
> > INFO: Returning with code 0x100
> > INFO: 11/30/2007 23:14:32
> > INFO: ****************************************
> > INFO: 11/30/2007 23:48:26
> > INFO: Product Version 2.1.0.0 <http://2.1.0.0/> .
> > INFO: Version: 6.0.6000
> > INFO: Platform ID: 2 (NT)
> > INFO: Service Pack: 0.0
> > INFO: Suite: 0x0300, Product Type: 1
> > INFO: Architecture: X86.
> > INFO: Interactive Windows Station
> > INFO: Command Line:
> > '"C:\Users\Caroline\Desktop\1wire\test\DPInst\DPInst.exe" '
> > INFO: DPInst is not multi-lingual.
> > INFO: ****************************************
> > INFO: Current working directory:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: Running on path
> 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: No valid 'dpinst.xml' file provided.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\ds2490winusb_x86.inf'.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\winusb.inf'.
> > INFO: Preinstalling
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf'.
> >
> SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\ds2490winu
> sb_x86.inf
> > is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: Preinstalling
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf'.
> > SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.
> inf' (Plug
> > and
> > Play).
> > INFO: Looking for Model Section [DS2490_WinUSB.NTx86]...
> > INFO: Installing devices with Id
> "USB\VID_04FA&PID_2490&REV_0002" using
> > INF
> >
> "C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf".
> > INFO: ENTER UpdateDriverForPlugAndPlayDevices...
> > ERROR: RETURN UpdateDriverForPlugAndPlayDevices. (Error
> code 0x2: Det går
> > inte att hitta filen.)
> > ERROR: Installation failed. (Error code 0x2: Det går inte att hitta
> > filen.)
> > ERROR: PnP Install failed. (Error code 0x2: Det går inte att hitta
> > filen.)
> > INFO: Attempting to rollback ...
> > INFO: No devices to rollback
> > INFO: RETURN: DriverPackageInstallW (0x2)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf'
> (Plug and Play).
> > WARNING:No device Ids found in INF
> >
> 'C:\Windows\System32\DriverStore\FileRepository\winusb.inf_036
> 2a280\winusb.i
> > nf' for current platform.
> > INFO: RETURN: DriverPackageInstallW (0xE0000301)
> > WARNING:No device Ids found in INF
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf' for current
> > platform.
> > INFO: Returning with code 0x80010000
> > INFO: 11/30/2007 23:48:43
> > INFO: ****************************************
> > INFO: 11/30/2007 23:49:00
> > INFO: Product Version 2.1.0.0 <http://2.1.0.0/> .
> > INFO: Version: 6.0.6000
> > INFO: Platform ID: 2 (NT)
> > INFO: Service Pack: 0.0
> > INFO: Suite: 0x0300, Product Type: 1
> > INFO: Architecture: X86.
> > INFO: Interactive Windows Station
> > INFO: Command Line:
> > '"C:\Users\Caroline\Desktop\1wire\test\DPInst\DPInst.exe" '
> > INFO: DPInst is not multi-lingual.
> > INFO: ****************************************
> > INFO: Current working directory:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: Running on path
> 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: No valid 'dpinst.xml' file provided.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\ds2490winusb_x86.inf'.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\winusb.inf'.
> > INFO: Preinstalling
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf'.
> >
> SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\ds2490winu
> sb_x86.inf
> > is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: Preinstalling
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf'.
> > SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.
> inf' (Plug
> > and
> > Play).
> > INFO: Looking for Model Section [DS2490_WinUSB.NTx86]...
> > INFO: Installing devices with Id
> "USB\VID_04FA&PID_2490&REV_0002" using
> > INF
> >
> "C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf".
> > INFO: ENTER UpdateDriverForPlugAndPlayDevices...
> > ERROR: RETURN UpdateDriverForPlugAndPlayDevices. (Error
> code 0x2: Det går
> > inte att hitta filen.)
> > ERROR: Installation failed. (Error code 0x2: Det går inte att hitta
> > filen.)
> > ERROR: PnP Install failed. (Error code 0x2: Det går inte att hitta
> > filen.)
> > INFO: Attempting to rollback ...
> > INFO: No devices to rollback
> > INFO: RETURN: DriverPackageInstallW (0x2)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf'
> (Plug and Play).
> > WARNING:No device Ids found in INF
> >
> 'C:\Windows\System32\DriverStore\FileRepository\winusb.inf_036
> 2a280\winusb.i
> > nf' for current platform.
> > INFO: RETURN: DriverPackageInstallW (0xE0000301)
> > WARNING:No device Ids found in INF
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf' for current
> > platform.
> > INFO: Returning with code 0x80010000
> > INFO: 11/30/2007 23:49:08
> > INFO: ****************************************
> > INFO: 11/30/2007 23:49:19
> > INFO: Product Version 2.1.0.0 <http://2.1.0.0/> .
> > INFO: Version: 6.0.6000
> > INFO: Platform ID: 2 (NT)
> > INFO: Service Pack: 0.0
> > INFO: Suite: 0x0300, Product Type: 1
> > INFO: Architecture: X86.
> > INFO: Interactive Windows Station
> > INFO: Command Line:
> > '"C:\Users\Caroline\Desktop\1wire\test\DPInst\DPInst.exe" '
> > INFO: DPInst is not multi-lingual.
> > INFO: ****************************************
> > INFO: Current working directory:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: Running on path
> 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: No valid 'dpinst.xml' file provided.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\ds2490winusb_x86.inf'.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\winusb.inf'.
> > INFO: Preinstalling
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf'.
> >
> SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\ds2490winu
> sb_x86.inf
> > is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: Preinstalling
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf'.
> > SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.
> inf' (Plug
> > and
> > Play).
> > INFO: Looking for Model Section [DS2490_WinUSB.NTx86]...
> > INFO: Installing devices with Id
> "USB\VID_04FA&PID_2490&REV_0002" using
> > INF
> >
> "C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf".
> > INFO: Installation did not occur because the hardware
> isn't currently
> > present.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Failed to get rescan data for Phantom Device with
> > Hardware/Compatible Id 'USB\VID_04FA&PID_2490&REV_0002'.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: No drivers installed. No devices found that match driver(s)
> > contained in
> >
> 'C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf'.
> > INFO: RETURN: DriverPackageInstallW (0xE000020B)
> > INFO: No matching device was found for
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.
> inf'. Driver
> > will be installed when plugged in.
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf'
> (Plug and Play).
> > WARNING:No device Ids found in INF
> >
> 'C:\Windows\System32\DriverStore\FileRepository\winusb.inf_036
> 2a280\winusb.i
> > nf' for current platform.
> > INFO: RETURN: DriverPackageInstallW (0xE0000301)
> > WARNING:No device Ids found in INF
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf' for current
> > platform.
> > INFO: Returning with code 0x100
> > INFO: 11/30/2007 23:50:30
> > INFO: ****************************************
> > INFO: 12/01/2007 00:04:21
> > INFO: Product Version 2.1.0.0 <http://2.1.0.0/> .
> > INFO: Version: 6.0.6000
> > INFO: Platform ID: 2 (NT)
> > INFO: Service Pack: 0.0
> > INFO: Suite: 0x0300, Product Type: 1
> > INFO: Architecture: X86.
> > INFO: Interactive Windows Station
> > INFO: Command Line:
> > '"C:\Users\Caroline\Desktop\1wire\test\DPInst\DPInst.exe" '
> > INFO: DPInst is not multi-lingual.
> > INFO: ****************************************
> > INFO: Current working directory:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: Running on path
> 'C:\Users\Caroline\Desktop\1wire\test\DPInst'
> > INFO: No valid 'dpinst.xml' file provided.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\ds2490winusb_x86.inf'.
> > INFO: Found driver package:
> > 'C:\Users\Caroline\Desktop\1wire\test\DPInst\winusb.inf'.
> > INFO: Preinstalling
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.inf'.
> >
> SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\ds2490winu
> sb_x86.inf
> > is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: Preinstalling
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf' ...
> > INFO: ENTER: DriverPackagePreinstallW
> > INFO: Driver package is already preinstalled
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf'.
> > SUCCESS:c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf is
> > preinstalled.
> > INFO: RETURN: DriverPackagePreinstallW (0xB7)
> > INFO: ENTER: DriverPackageGetPathW
> > INFO: RETURN: DriverPackageGetPathW (0x0)
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.
> inf' (Plug
> > and
> > Play).
> > INFO: Looking for Model Section [DS2490_WinUSB.NTx86]...
> > INFO: Installing devices with Id
> "USB\VID_04FA&PID_2490&REV_0002" using
> > INF
> >
> "C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf".
> > INFO: Installation did not occur because the hardware
> isn't currently
> > present.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: Found Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002'
> > INFO: Marked Phantom Device with Hardware/Compatible Id
> > 'USB\VID_04FA&PID_2490&REV_0002' for rescan on next plug-in.
> > INFO: No drivers installed. No devices found that match driver(s)
> > contained in
> >
> 'C:\Windows\System32\DriverStore\FileRepository\ds2490winusb_x
> 86.inf_ace40aa
> > 2\ds2490winusb_x86.inf'.
> > INFO: RETURN: DriverPackageInstallW (0xE000020B)
> > INFO: No matching device was found for
> >
> 'c:\users\caroline\desktop\1wire\test\dpinst\ds2490winusb_x86.
> inf'. Driver
> > will be installed when plugged in.
> > INFO: ENTER: DriverPackageInstallW
> > INFO: Installing INF file
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf'
> (Plug and Play).
> > WARNING:No device Ids found in INF
> >
> 'C:\Windows\System32\DriverStore\FileRepository\winusb.inf_036
> 2a280\winusb.i
> > nf' for current platform.
> > INFO: RETURN: DriverPackageInstallW (0xE0000301)
> > WARNING:No device Ids found in INF
> > 'c:\users\caroline\desktop\1wire\test\dpinst\winusb.inf' for current
> > platform.
> > INFO: Returning with code 0x100
> > INFO: 12/01/2007 00:04:27
> >
> >
> >
> > 2007/11/6, Sjölöfs < sjolof@gmail.com <mailto:sjolof@gmail.com> >:
> >
> > Hi Brian,
> >
> > Sad to say that it didn´t work. I´m looking forward to your
> "something to
> > test"-version ;).
> >
> > I´m really happy that you are helping me out. I´ve made a
> system that is
> > integrated in our new house that we are building, and the
> weather device
> > is
> > the last thing I need to get working. Switching back to XP
> would mean a
> > lot
> > of work for me.
> >
> > /Magnus
> >
> >
> > 2007/11/5, Brian Hindman < Brian.Hindman@dalsemi.com
> > <mailto:Brian.Hindman@dalsemi.com> >:
> >
> >
> > Hi. It looks like the installation package is working
> properly until it
> > finds the remains of a previous install (a "phantom node").
> It then goes
> > for the "previous" install and avoids the nice new one.
> >
> > You also might be able to just plug-in the DS9490, find the
> the device in
> > Device Manager, right click on the correct entry and click on the
> > "Uninstall" pop-up menu option. The window that pops up in
> Vista should
> > offer you a checkbox that says "Delete the driver software for this
> > device".
> > Check this box and continue with the uninstall.
> >
> > Once this is done, unplug the DS9490, wait a few seconds and then
> > re-install
> > the software and see what happens.
> >
> > If this doesn't work, I'll see if I can get something for
> you to test soon
> > (with DPInst.exe) that will hopefully overwrite the bad install.
> >
> > Regards,
> >
> > --Brian Hindman,
> > Maxim Integrated Products, Dallas
> >
> > -----Original Message-----
> > From: Sjölöfs [mailto: <mailto:sjolof@gmail.com> sjolof@gmail.com]
> >
> > Sent: Saturday, November 03, 2007 3:34 PM
> > To: Brian Hindman
> > Subject: Re: Can't send an attachment to you
> >
> >
> >
> > Any news?
> >
> > Regards,
> > Magnus
> >
> >
> > 2007/10/30, Brian Hindman < Brian.Hindman@dalsemi.com
> > <mailto:Brian.Hindman@dalsemi.com> >:
> >
> > Interesting. I'll get back to you tomorrow on the log file...
> >
> > --Brian Hindman,
> > Maxim Integrated Products, Maxim
> >
> > -----Original Message-----
> > From: Sjölöfs [mailto: <mailto:sjolof@gmail.com> sjolof@gmail.com]
> > Sent: Monday, October 29, 2007 6:17 PM
> > To: Brian Hindman
> > Subject: Re: Can't send an attachment to you
> >
> >
> >
> > Haven´t found the files you requested, but I found
> DPINST.LOG wich looks
> > intresting (look in the end).
> > Will try to find the files you wanted.
> >
> > See attached from my both Vista computers.
> >
> >
> > /Magnus
> >
> >
> > 2007/10/29, Brian Hindman < Brian.Hindman@dalsemi.com
> > <mailto:Brian.Hindman@dalsemi.com> >:
> >
> > Hi. When you install a device driver, apparently, logs are
> created each
> > time you attempt the installation. Please send me your
> > (%windir%\setup*.log) and wdf log (%windir%\wdf*.log) files
> (so I can take
> > a
> > look).
> >
> >
> > --Brian Hindman,
> > Maxim Integrated Products, Dallas
> >
> > -----Original Message-----
> > From: Sjölöfs [mailto: sjolof@gmail.com <mailto:sjolof@gmail.com> ]
> > Sent: Monday, October 29, 2007 4:14 PM
> > To: Brian Hindman
> > Subject: Re: Can't send an attachment to you
> >
> >
> >
> > Brian,
> >
> > I got you email with the attachment and tried it (dpinst)
> and it behaved
> > exactly the samefor me (fie missing... etc).
> >
> > I´m really sorry that I´m not having any Vista Business... Would be
> > interesting to see...
> > As I told you earlier I´ve made the installation on 2
> different Vista Home
> > Premium with no luck, and on 1 XP machine where it worked
> as it should...
> >
> > Any ideas?
> >
> > /Magnus
> >
> > 2007/10/26, Brian Hindman < Brian.Hindman@dalsemi.com
> > <mailto:Brian.Hindman@dalsemi.com> >:
> >
> > Hi. Do you have an alternate e-mail address?
> Specifically, one that can
> > handle >1 Mb of an attachment ...
> >
> > Thanks,
> > --Brian Hindman,
> > Maxim Integrated Products, Dallas
> >
> >
> >
> > No virus found in this incoming message.
> > Checked by AVG Free Edition.
> > Version: 7.5.488 / Virus Database: 269.15.10/1092 - Release Date:
> > 10/25/2007
> > 1:14 PM
> >
> >
> >
> >
> > No virus found in this incoming message.
> > Checked by AVG Free Edition.
> > Version: 7.5.488 / Virus Database: 269.15.10/1092 - Release Date:
> > 10/25/2007
> > 1:14 PM
> >
> >
> >
> >
> >
> >
> >
> >
> > No virus found in this incoming message.
> > Checked by AVG Free Edition.
> >
> > Version: 7.5.488 / Virus Database: 269.15.17/1103 - Release Date:
> > 11/1/2007
> > 6:01 AM
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > No virus found in this incoming message.
> > Checked by AVG Free Edition.
> >
> > Version: 7.5.488 / Virus Database: 269.16.7/1151 - Release Date:
> > 11/25/2007
> > 4:24 PM
> >
> >
> >
> >
> >
> >
> >
> >
> > No virus found in this incoming message.
> > Checked by AVG Free Edition.
> > Version: 7.5.488 / Virus Database: 269.16.13/1165 - Release Date:
> > 12/2/2007
> > 8:34 PM
> >
> >
> >
>
>
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.5.488 / Virus Database: 269.17.4/1188 - Release
> Date: 12/17/2007 2:13 PM
>
>

PerM
Hemautomation - det är mer än en hobby
Inlägg: 822
Blev medlem: 23 feb 2007, 14:46
Ort: Vallentuna
Kontakt:

Inlägg av PerM » 23 dec 2007, 02:48

Kul att det fungerade för dig också. Om Maxim killen återkommer, hälsa att en viss entusiast har bättre koll på deras grejer dom dom själva :D

Släger ut en fråga, kanske nån som vet detta:
Hur får man Visual Studio 2005 att länka mot ibfs32.lib som följer med i TMEXWrap_Win32 i deras Public Domain källkod? Allt kompilerar, men länkaren klagar på unresolved externals.....argh, vad jag är trött på detta strul!

sjolof
Wannabe
Inlägg: 7
Blev medlem: 24 okt 2007, 22:53
Ort: Lysekil

Inlägg av sjolof » 23 dec 2007, 15:03

PerM skrev:Kul att det fungerade för dig också. Om Maxim killen återkommer, hälsa att en viss entusiast har bättre koll på deras grejer dom dom själva :D
Ska bli!!!

Skriv svar