Få klockan att gå rätt

Generella Linux-frågor och frågor gällande Linuxmjukvara som saknar egen forumkategori skall postas i detta forum

Moderator: elf98

Kategoriregler
Vill du visa bilder i ditt inlägg? Använd funktionen "Ladda upp bilaga" nedanför textrutan!
NoiseMaker
Gillar hemautomation
Inlägg: 46
Blev medlem: 06 dec 2013, 23:06
Ort: Norra Sverige, vid kusten

Få klockan att gå rätt

Inlägg av NoiseMaker » 15 dec 2014, 13:50

Har haft min paj i några månader nu och den fungerar helt okej. Ett välkänt problem är att den saknar klocka något som jag först försökte lösa med något program som automatiskt skulle ställa den rätt i små steg så att man slapp konstigheter i graferna (om tiden plötsligt gör ett stort hopp). Jag har sökt och sökt på webben, men hittar inte tillbaka till det. (Finns det något sätt att se vilka program man har installerade på sin paj? Jag använder SSH för access.)

För att lösa problemet skaffade jag en DS3231 men jag lyckas inte få den att gå rätt. Jag tror att jag har lyckats föra över aktuellt datum till RTC:n, men grejen är att jag aldrig får Pajen att hämta rätt tid. När jag gjorde överföringen trodde den att det var någon gång i mars 1970. Eller om det var 2000, har sett lite olika vid olika tillfällen. Hur som helst, om inte Pajen hämtar aktuell tid så går den ju inte att föra över till RTC:n. Jag saknar också möjligheten att manuellt mata in tid och datum.

Jag har följt anvisningarna i den här tråden:
http://www.raspberrypi.org/forums/viewt ... 66&t=85683
och den här:
https://learn.adafruit.com/adding-a-rea ... t-rtc-time

Jag kan inte prata linuxska så jag förstår bara hjälpligt vad de olika kommandona gör.
Jag har Domoticz v. 2.2025 vet inte vilket underliggande OS, men jag tror det är Raspbian.

Användarvisningsbild
Foxmaster
Wannabe
Inlägg: 7
Blev medlem: 23 okt 2013, 08:52
Ort: Nordmaling

Re: Få klockan att gå rätt

Inlägg av Foxmaster » 15 dec 2014, 23:36

Hej.
Ntpd borde funka skulle jag tro.

NoiseMaker
Gillar hemautomation
Inlägg: 46
Blev medlem: 06 dec 2013, 23:06
Ort: Norra Sverige, vid kusten

Re: Få klockan att gå rätt

Inlägg av NoiseMaker » 16 dec 2014, 10:29

Jag har redan angett en server i /etc/ntp.conf, men det verkar inte hjälpa.

flyvert
Hemautomation - det är mer än en hobby
Inlägg: 385
Blev medlem: 22 aug 2013, 00:48
Ort: Västerås

Re: Få klockan att gå rätt

Inlägg av flyvert » 16 dec 2014, 19:09

Min erfarenhet är att Raspbian (Debian för Raspberry Pi) default söker efter välkända NTP-servrar o synkar automatiskt?

[relaterade rader från min icke-moddade /etc/ntp.conf]
# pool.ntp.org maps to about 1000 low-stratum NTP servers. Your server will
# pick a different set every time it starts up. Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
server 0.debian.pool.ntp.org iburst
server 1.debian.pool.ntp.org iburst
server 2.debian.pool.ntp.org iburst
server 3.debian.pool.ntp.org iburst


Har bara haft problem om internetuppkopplingen låg nere vid senaste reboot, annars fungerar det klockrent för mina pajer.

- Problem med DNS?
- Problem med internetuppkopplingen?
- Port 123 (UDP) spärrad i brandväggen?

Går NTP servicen? Kan du starta om den?
$ sudo service ntp status
[ ok ] NTP server is running.

$ sudo service ntp restart
[ ok ] Stopping NTP server: ntpd.
[ ok ] Starting NTP server: ntpd.



Kolla DNS / namnuppslagning
$ sudo apt-get install dnsutils
$ dig 0.debian.pool.ntp.org

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> 0.debian.pool.ntp.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63804
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;0.debian.pool.ntp.org. IN A

;; ANSWER SECTION:
0.debian.pool.ntp.org. 59 IN A 194.71.144.71
0.debian.pool.ntp.org. 59 IN A 94.245.35.13
0.debian.pool.ntp.org. 59 IN A 217.75.106.216


;; Query time: 27 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Tue Dec 16 17:28:32 2014
;; MSG SIZE rcvd: 87


Felutskrifter från ntpd?
$ grep ntpd /var/log/daemon.log
Dec 16 17:17:23 RPI1 ntpd[2089]: ntpd 4.2.6p5@1.2349-o Fri May 18 20:30:57 UTC 2012 (1)
Dec 16 17:17:23 RPI1 ntpd[2093]: proto: precision = 1.000 usec
Dec 16 17:17:23 RPI1 ntpd[2093]: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123
Dec 16 17:17:23 RPI1 ntpd[2093]: Listen normally on 1 lo 127.0.0.1 UDP 123
Dec 16 17:17:23 RPI1 ntpd[2093]: Listen normally on 2 eth0 192.168.1.121 UDP 123
Dec 16 17:17:23 RPI1 ntpd[2093]: peers refreshed
Dec 16 17:17:23 RPI1 ntpd[2093]: Listening on routing socket on fd #19 for interface updates
Dec 16 17:17:23 RPI1 ntpd[2093]: restrict: error in address '::' on line 38. Ignoring...
Dec 16 17:17:23 RPI1 ntpd[2093]: restrict: error in address '::1' on line 42. Ignoring...
Dec 16 19:24:59 RPI1 ntpd[2093]: ntpd exiting on signal 15 (Här startar jag om den med sudo service ntp restart)
Dec 16 19:25:01 RPI1 ntpd[10070]: ntpd 4.2.6p5@1.2349-o Fri May 18 20:30:57 UTC 2012 (1)
Dec 16 19:25:01 RPI1 ntpd[10071]: proto: precision = 1.000 usec
Dec 16 19:25:01 RPI1 ntpd[10071]: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123
Dec 16 19:25:01 RPI1 ntpd[10071]: Listen normally on 1 lo 127.0.0.1 UDP 123
Dec 16 19:25:01 RPI1 ntpd[10071]: Listen normally on 2 eth0 192.168.1.121 UDP 123
Dec 16 19:25:01 RPI1 ntpd[10071]: peers refreshed
Dec 16 19:25:01 RPI1 ntpd[10071]: Listening on routing socket on fd #19 for interface updates
Dec 16 19:25:01 RPI1 ntpd[10071]: restrict: error in address '::' on line 38. Ignoring...
Dec 16 19:25:01 RPI1 ntpd[10071]: restrict: error in address '::1' on line 42. Ignoring...


Ladda hem nätverkssniffer o kolla vad som händer på nätverket?
$ sudo apt-get install tcpdump
$ sudo tcpdump -i eth0 udp port 123
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
17:22:29.082647 IP 192.168.1.121.ntp > Time4.Stupi.SE.ntp: NTPv4, Client, length 48
17:22:29.085928 IP Time4.Stupi.SE.ntp > 192.168.1.121.ntp: NTPv4, Server, length 48



/f
Om traktorn stjälper; håll i ratten, hoppa ej!

larky
Moderator
Inlägg: 974
Blev medlem: 01 feb 2008, 12:21
Ort: Skellefteå
Kontakt:

Re: Få klockan att gå rätt

Inlägg av larky » 16 dec 2014, 21:38

Ntp borde funka attomatiskt om det finns internetåtkomst.

NoiseMaker
Gillar hemautomation
Inlägg: 46
Blev medlem: 06 dec 2013, 23:06
Ort: Norra Sverige, vid kusten

Re: Få klockan att gå rätt

Inlägg av NoiseMaker » 17 dec 2014, 11:42

Borde hjälper inte när det de facto inte fungerar. Internetåtkomst finns, jag kan pinga NTP-servern. Ska kolla mer på flyverts inlägg då jag har tid.

Användarvisningsbild
Plutonium
Moderator
Inlägg: 1186
Blev medlem: 04 jan 2008, 02:34
Ort: Nossebro
Kontakt:

Re: Få klockan att gå rätt

Inlägg av Plutonium » 18 dec 2014, 16:04

Jag är ganska "lat" av mig så jag brukar lägga in i cron och körs en gång / dygn.
"ntpdate ntp.kth.se"


Skickas från min iPhone via Tapatalk
http://essunga.org
Moderator - Temperatur.nu

flyvert
Hemautomation - det är mer än en hobby
Inlägg: 385
Blev medlem: 22 aug 2013, 00:48
Ort: Västerås

Re: Få klockan att gå rätt

Inlägg av flyvert » 20 dec 2014, 12:14

Plutonium skrev:Jag är ganska "lat" av mig så jag brukar lägga in i cron och körs en gång / dygn.
"ntpdate ntp.kth.se"
Hmm... du borde kunna vara latare än så Mr94 (Plutonium...) :D min erfarenhet säger mig att en NOOBS installation synkar av sig självt.

Om man googlar finner man fler som har haft problem, tex den här länken nämner nåt tjall pga DHCP men att reinstall fixade det: http://raspberrypi.stackexchange.com/qu ... iple-times

Glömde att nämna raspi-config - man bör nog välja korrekt tidzon för att det skall fungera (kanske det krävs för att klocksynkroniseringen skall starta?)
Om traktorn stjälper; håll i ratten, hoppa ej!

Skriv svar