X-Mas Lights, får inte igång den.

Teknisk support för produkter som finns på http://www.m.nu. Generella diskussioner rörande hårdvara hänvisas till teknikforumet.

Moderator: elf98

Kategoriregler
Vill du visa bilder i ditt inlägg? Använd funktionen "Ladda upp bilaga" nedanför textrutan!
bjornsson
Hemautomation - det är mer än en hobby
Inlägg: 403
Blev medlem: 25 aug 2010, 09:06
Ort: Bräcke

X-Mas Lights, får inte igång den.

Inlägg av bjornsson » 03 dec 2015, 09:58

Något tips på vad jag kan ha missat när jag inte får min julbelysning att fungera =)
Har lött ihop den själv, så inte helt omöjligt att det kan vara nått där. Men allt ser ok ut.
Jag kan programmera den och den spotar ur sig et OK.
Har ändrat
const int numStrands = 1; // number of LED strands to address
Misstänker att den ska stå på 1 då jag bara har en slinga? Den stod på 3 innan.

Några lampor tänds när jag pluggar in strömen i slinga, men det gör den även om jag inte har modulen inkopplad.
POW på Arduino Nano tänds och lyser rött, ingen utav de andra tre.


Update:
https://www.arduino.cc/en/Guide/ArduinoNano
Enligt den sidan ska det lysa en blå diod på undersidan, men det gör det inte.
Ska jag löda bort den igen och testa koppla in den utan att ha den monterad?
bjornsson
Hemautomation - det är mer än en hobby
Inlägg: 403
Blev medlem: 25 aug 2010, 09:06
Ort: Bräcke

Re: X-Mas Lights, får inte igång den.

Inlägg av bjornsson » 03 dec 2015, 13:56

Kod: Markera allt

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM5
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
         AVR Part                      : ATmega328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : Arduino
         Description     : Arduino
         Hardware Version: 2
         Firmware Version: 1.16
         Vtarget         : 0.0 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f
avrdude: reading input file "C:\Users\81060582\AppData\Local\Temp\build65a5aca9c4640dedaaed4c90d50f288f.tmp/Xmas_lights_by_mnu_2EF.ino.hex"
avrdude: writing flash (6148 bytes):

Writing | ################################################## | 100% 1.77s

avrdude: 6148 bytes of flash written
avrdude: verifying flash memory against C:\Users\81060582\AppData\Local\Temp\build65a5aca9c4640dedaaed4c90d50f288f.tmp/Xmas_lights_by_mnu_2EF.ino.hex:
avrdude: load data flash data from input file C:\Users\81060582\AppData\Local\Temp\build65a5aca9c4640dedaaed4c90d50f288f.tmp/Xmas_lights_by_mnu_2EF.ino.hex:
avrdude: input file C:\Users\81060582\AppData\Local\Temp\build65a5aca9c4640dedaaed4c90d50f288f.tmp/Xmas_lights_by_mnu_2EF.ino.hex contains 6148 bytes
avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 1.32s

avrdude: verifying ...
avrdude: 6148 bytes of flash verified

avrdude done.  Thank you.
Senast redigerad av 1 bjornsson, redigerad totalt 3 gånger.
bjornsson
Hemautomation - det är mer än en hobby
Inlägg: 403
Blev medlem: 25 aug 2010, 09:06
Ort: Bräcke

Re: X-Mas Lights, får inte igång den.

Inlägg av bjornsson » 03 dec 2015, 18:30

Kör jag in denna kod får jag en lampa att skina i 5sek och sedan vara släckt 1 sek.
Så den verkar ju ok, hur felsöker jag för att kolla så jag lött resten rätt. Har kollat och dubbelkollat flera ggr nu men ser ok ut :P

Kod: Markera allt

/*
  Blink
  Turns on an LED on for one second, then off for one second, repeatedly.

  Most Arduinos have an on-board LED you can control. On the Uno and
  Leonardo, it is attached to digital pin 13. If you're unsure what
  pin the on-board LED is connected to on your Arduino model, check
  the documentation at http://www.arduino.cc

  This example code is in the public domain.

  modified 8 May 2014
  by Scott Fitzgerald
 */


// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin 13 as an output.
  pinMode(13, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(13, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(5000);              // wait for a second
  digitalWrite(13, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);              // wait for a second
}
Användarvisningsbild
elf98
Hemautomation - det är mer än en hobby
Inlägg: 5225
Blev medlem: 27 okt 2006, 13:49
Ort: Linköping
Kontakt:

Re: X-Mas Lights, får inte igång den.

Inlägg av elf98 » 03 dec 2015, 22:31

Ta ett foto. Sannolikt är det någon av kablarna på 7 eller 9 som inte är rätt.

Vilken av dioderna är det som blinkar? Första eller sista? Om det är sista kan du testa att vända på slingan så sidan som blinkar sitter närmast kontrollern.
Grundade m.nu & temperatur.nu

Bild Bild
bjornsson
Hemautomation - det är mer än en hobby
Inlägg: 403
Blev medlem: 25 aug 2010, 09:06
Ort: Bräcke

Re: X-Mas Lights, får inte igång den.

Inlägg av bjornsson » 04 dec 2015, 08:29

Det är dioden L på själva kortet som jag får att blinka med den andra koden.
Själva ljusslingan reagerar inte alls, det tänds lite random så fort jag pluggar in strömmen i den. Ibland tänds en 12-15st och drar jag ur och stoppar i den igen så tänds 3-4 och ibland bara 1.


När jag programmerar den, vad ska jag välja under "Verktyg" och sedan "Programmerare"?
Bilagor
IMG_0629.JPG
IMG_0627.JPG
IMG_0628.JPG
Användarvisningsbild
elf98
Hemautomation - det är mer än en hobby
Inlägg: 5225
Blev medlem: 27 okt 2006, 13:49
Ort: Linköping
Kontakt:

Re: X-Mas Lights, får inte igång den.

Inlägg av elf98 » 04 dec 2015, 13:06

Om du får ok när du programmerar så är den biten rätt.

Om det tänds lite dioder när du ansluter spännignsmatning är röd och blå kabel rätt (spänningsmatning.

Kan du ta kort på undersidan av kortet? Något är knas med gul och grön kabel och dess väg till nanon.
Grundade m.nu & temperatur.nu

Bild Bild
bjornsson
Hemautomation - det är mer än en hobby
Inlägg: 403
Blev medlem: 25 aug 2010, 09:06
Ort: Bräcke

Re: X-Mas Lights, får inte igång den.

Inlägg av bjornsson » 04 dec 2015, 13:45

elf98 skrev:Om du får ok när du programmerar så är den biten rätt.

Om det tänds lite dioder när du ansluter spännignsmatning är röd och blå kabel rätt (spänningsmatning.

Kan du ta kort på undersidan av kortet? Något är knas med gul och grön kabel och dess väg till nanon.

Kopplar jag in slingan bakvänt. Alltså sätter hanen från kontrollern till hanen på slingan istället för honan så går den igång och fungerar.
Kan den vara felkontakterad bara?
Användarvisningsbild
elf98
Hemautomation - det är mer än en hobby
Inlägg: 5225
Blev medlem: 27 okt 2006, 13:49
Ort: Linköping
Kontakt:

Re: X-Mas Lights, får inte igång den.

Inlägg av elf98 » 04 dec 2015, 13:49

Japp, du kan ha fått bakvänd slinga.

Bra att det fungerar. Vill du ha en adapter? eller löser du det ändå?
Grundade m.nu & temperatur.nu

Bild Bild
bjornsson
Hemautomation - det är mer än en hobby
Inlägg: 403
Blev medlem: 25 aug 2010, 09:06
Ort: Bräcke

Re: X-Mas Lights, får inte igång den.

Inlägg av bjornsson » 04 dec 2015, 13:50

elf98 skrev:Japp, du kan ha fått bakvänd slinga.

Bra att det fungerar. Vill du ha en adapter? eller löser du det ändå?
Jag klipper och löder om kontakterna så det bli rätt :)
Men tack ändå :D
Skriv svar